Just a short note that ActiveScaffold might be used with jquery 1.4.4 since today.

If you use setup generator your application will be automatically configured to use jquery 1.4.4.

If you would like to update your existing activescaffold application please read following guide:

Change application.html.erb

...
<%= stylesheet_link_tag 'http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.9/themes/ui-lightness/jquery-ui.css' %>
...
<%= javascript_include_tag 'http://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.js' %>
<%= javascript_include_tag 'http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.9/jquery-ui.js' %>

Update rails.js

Replace existing one in public/javascripts by https://github.com/vhochstein/jquery-ujs/raw/master/src/rails.js

That s it. Please note that you ve just included non minified versions of jquery.

In case of any issue… please open an issue.

Advertisements